IonCube Loader is a software instrument, which is required to run files that are protected with ionCube PHP Encoder. The aforementioned is an app used to make PHP code human unreadable, as a way to protect it from reverse engineering and not authorized use. A great number of script-driven apps, particularly online forums, content management systems and electronic commerce solutions are encrypted with ionCube PHP Encoder, therefore when you purchase a script and you find that ionCube is among the website hosting environment prerequisites, you should make sure that your web hosting server has the instrument pre-installed. While it's not that difficult to install it if you have your own server, it's almost impossible to do that on a shared web hosting server due to the fact that the PHP environment should be precompiled and all of the clients on the server shall be affected.

IonCube in Cloud Hosting

IonCube Loader is available on all of the web servers which are part of our cloud web hosting platform, so regardless of the Linux cloud hosting that you choose during the signup process, you can activate it through your Hepsia Control Panel. This process is as simple as clicking an On/Off button in the Advanced section, so even if this is your first web hosting account ever, you will not have to do anything complex. The same section allows you to select the PHP version for your account (4, 5.2, 5.3, 5.4, 5.5), and if you decide to switch to another version, you just have to activate ionCube Loader for it too. As our platform is flexible, you can set another PHP version and another status of ionCube by using a php.ini file in every domain folder. If this is something you wish to do but you do not have much experience, our 24/7 technical support team will help you in no time.

IonCube in Semi-dedicated Servers

In case you aquire a semi-dedicated server package from our company, you can take advantage of any script-driven application that needs ionCube Loader due to the fact that the software tool is available on all the servers that are part of our advanced cloud hosting platform. Furthermore, we support different releases of PHP, which means that if you move from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for that particular release with only a click from your Hepsia Control Panel. Our system will remember your decision, so in case you move back to the previous release of PHP, the tool will already be active. For more tech-savvy users, we also offer the option to pick the PHP version and if ionCube will be active or not for a specific domain name without altering the settings for the entire web hosting account. This can be done by putting a php.ini file in a domain folder with a few lines of program code.